IPR Window

The IPR window consists of a toolbar, the image area, and a status bar

 

The Arnold IPR window is designed to give real-time feedback on changes made in the scene, offering a significant workflow speed-up. The Interactive Preview Render window will automatically update the render every time it detects a change in the scene (such as moving the camera, objects or lights, or any kind of lighting or shading modification). This speeds up your workflow as it is not necessary to keep starting new renders because the IPR is constantly updating for you.

 

The interactive preview render uses a progressive refinement method to provide a fast response. The image is rendered several times by increasing the AA samples in each of the steps (previous steps are not reused). The render will complete when the target AA is achieved (it will output the same image as the final frame render). You can change the step settings of the progressive refinement in the Arnold render settings.

While the IPR is running, material previews are not rendered because only one render session can be active in Arnold at the moment. If you stop the IPR then the material previews will be updated. The last rendered preview is displayed with a small orange frame showing that the preview is delayed. The IPR will also stop if you start a render from the Picture Viewer due to the same reason.

The IPR requires the viewport (editor) window to be open. If the viewport window is closed, the IPR does not update any changes, resulting in an invalid state. This is a limitation in C4D as it stops calling the Arnold scene hook when the viewport window is closed.

C4D's built-in IRR (Interactive Render Region) feature also works with Arnold, however, it has a lot of limitations and it's not recommended. Use this IPR window instead.

Toolbar

The visibility of toolbar items can be specified via the View > Toolbar menu.

 

Play

You can use the play  button on the toolbar to start and stop the interactive render. It's a two-state button, highlighted if the IPR session is active. Render starts automatically when the IPR window opens.

Pause

The pause button stops updating (re-export and re-render) the scene until it is released and collects all changes in the background. It's useful to save time between multiple changes when the scene export takes too long.

Scale

Defines the resolution of the interactive render by scaling the final render resolution (Render settings/Output). A lower resolution gives faster interactive render times without affecting your scene settings.

Resolution (custom)

Defines the resolution of the interactive render independently from the final render resolution. A lower resolution gives faster interactive render times without affecting your scene settings.

The widget has a popup menu where presets are listed (similar to the resolution in the Render Settings). The ratio can also be locked which means the width and height updates automatically when changing the other component.

Zoom

The Zoom level of the image area.  Works the same way as zoom in the Picture Viewer. You can also use the mouse wheel to zoom in or out of the image. Zoom does not affect the render time or quality of the IPR.

Display Settings 

This button  enables or disables the display settings (e.g. color correction, LUT) in the IPR window. The display settings are applied to the color corrected (view color space) render output and affect only the IPR window (they are not applied to the PV or batch render).

Debug Shading

This button enables or disables debug shading mode. The active debug shading mode can be defined in the Render > Debug shading menu.

Render Region

Use the render region tool  to marquee select an area within the IPR window that you wish to render. You can press Shift and left mouse button to define the region. You can also use the boxes on the corners and sides of the region to define the area that you want to update and the center box to move the region around the IPR window. The selected region in the IPR window will update as you adjust the scene. This speeds up workflow when fine-tuning areas of a scene, such as a particular shader or lighting effect.  

Marquee region updates only that part of the rendered image

Render Selected Object

Use the render selected object tool  to re-render only those areas of the image (buckets) which contain the selected objects, instead of re-rendering a whole rectangular region. This speeds up workflow when fine-tuning areas of a scene, such as a particular shader or lighting effect. The feature works together with the Render Region.

Motion blur

This button  enables or disables the motion blur effect in the IPR when it's enabled in the scene. 

Motion blur requires a full copy of the scene by every change which affects performance. That's why motion blur is ignored by default.

Display

You can select an AOV to display in the IPR window. AOVs listed here have to be defined by the display driver. See the AOVs page about how to add AOVs to the scene.

Camera

You can select the render camera from the interactive preview. The box lists all Camera objects of the scene along with two special items:

  • <active camera>: always reflects the camera selected in the viewport.
  • <default camera>: the default C4D camera which is active when no Camera objects are activated.

Color Space

When enabled a Color Space combo box is visible in the toolbar, listing the available color spaces based on the active color manager (e.g. OCIO).

Render to the Picture Viewer and Team Render to the Picture Viewer and therefore the native Save won't match the custom color space in the IPR because of a limitation. The image in the Picture Viewer is always displayed in C4D's built-in sRGB color space.

Reload Textures

This button  allows you to quickly flush the texture cache and restart the IPR when you edit a texture file.

Snapshot

Click on this button  to send the current IPR image to the Picture Viewer. Making snapshots this way allows you to compare the output of different scene settings and also enables you to save the image to the disk. Render time and resolution is displayed in the Picture Viewer history natively. Custom information, such as sampling and memory usage is also imprinted into the name.

Snapshot information visible in Picture Viewer

Menu bar

View

Show Pixel Information

Displays the coordinates and color of the pixel under the mouse pointer in the status bar. The 32-bit RGB values in the render color space and the 8-bit RGB values in the view color space are both displayed.

You can sample a 5x5 pixel area under the mouse when pressing the Ctrl/Cmd key.

Show Display Settings

Opens the Display Settings panel on the right of the window.


Fit to Window

Updates the zoom to fit the image to the window.

Fit to Render Region

Moves the render region to the center and updates the zoom to fit the window.

Center Render Region

Updates the scrollbar and moves the render region to the center of the window.

Render 

 

Progressive Render

Completes the render call in multiple passes. During each of the intermediate passes, drivers that do not output to a file will be invoked after each tile has completed, which allows for display drivers to show a result whose noise progressively converges towards the result at the final Camera (AA) sample settings.

Note that this option slows down render times and increases memory usage, which is why it's only supported during interactive renders for fast preview.

 
Disabled (default)
Enabled

Render with AOVs

When enabled all AOVs are rendered at once which means the IPR does not restart when you change the displayed AOV. Could be useful for debugging complex scenes where you have to change between AOVs frequently.

Rendering all AOVs affects performance so recommended to be disabled by default.

Copy Region to Render Settings

When you enable Render Region in the IPR and click on 'Copy region to render settings', then the region (left, right, top, bottom) is set as the render region in the Render Settings window. This enables you to transfer the same region render dimensions to the Picture Viewer window.

Region render dimension setting copied to Render Settings window

Snapshot from Region Only

This flag controls if a snapshot should only be taken of the region (enabled) or the entire image (disabled). This is only used when region render is enabled.

Anamorphic Workflow

When enabled the IPR window shows the de-squeezed image, allowing you to work on the original pixel aspect.

Render to Viewport

Display the render on top of the viewport instead on the IPR window.

Debug Shading

Overrides the shading in the scene by the selected utility shader mode for debugging purposes.

Debug shading options

Clear Bitmap

Clears the bitmap (fills in with black).

Status Bar

 

The status bar provides information about the actual render and output. (Rendering...) label is displayed at the beginning of the status bar message while the interactive render is running. The following information about the render is presented in the following order:

  • Debug shading mode if enabled.
  • Render time.
  • Camera / Diffuse / Specular / Refraction / SSS / Volume indirect sampling rates. Check the Sampling page for more info.
  • Memory usage of the IPR process.
  • Resolution of the render.
  • Region dimensions if region render is enabled.
  • Pixel information when enabled.

Camera Controls

Camera controls are available in the IPR window, similar to the viewport:
  • Alt + LMB + move: Rotates the camera.
  • Alt + MMB + move: Moves the camera.

  • Alt + RMB + move: Moves the camera closer / farther (zoom in / out).

  • Alt + scroll: Moves the camera closer / farther with a unit (200 cm).

Alternatively, you can use 1,2,3 + LMB as well, similar to the viewport.

Controls are working only if the IPR is active.

In the viewport, zooming (scaling) moves the camera towards the object under the mouse cursor and speed depends on the distance from this object. In the IPR window, zooming (scaling) always moves the camera forward and with the same speed, independently from the mouse cursor.

Shortcuts

Keyboard shortcuts that you can use are in the IPR window:

  • Alt + W and F: Updates the zoom to fit the image to the window.

  • Alt + W and G: Moves the render region to the center and updates the zoom to fit the window.

  • Alt + W and H: Updates the scrollbar and moves the render region to the center of the window.
  • Alt + W and P: Pause the IPR.
  • Alt + W and R: Start/stop the IPR. Opens the IPR window when it's not visible.
  • Alt + W and S: Take a snapshot to the Picture Viewer.
  • Alt + W and T: Enable / disable region render.
  • Alt + W and V: Redirect render to the viewport.
  • S: Frame the view to all selected elements.
  • O: Frame the currently selected object.
  • H: Frame all.

You can change these shortcuts in Window > Customization > Customize Commands...

Other shortcuts using the mouse:

  • Shift + LMB + drag: Select an area within the IPR window that you wish to render.
  • Ctrl + LMB: Select the object under the mouse.
  • Ctrl + Shift + LMB: Adds/removes the object under the mouse to/from the selection.
  • Ctrl + Alt + LMBPick focus distance in the IPR window. If you have a camera with depth of field enabled you can simply change the focus by clicking on an object in the image.

Context Menu

context menu is available in the IPR window when you right click on an object.  

 

  •  Select object: Select the object under the mouse.
  • Append to selection / Remove from selection: Adds/removes the object under the mouse to/from the selection.
  • Pick focusPick focus distance in the IPR window. If you have a camera with depth of field enabled you can simply change the focus by clicking on an object in the image.
  • Create Arnold material: Create a new Arnold Shader Network material in the scene and assign it to the object under the mouse.


You can drag & drop a material onto an object rendered in the IPR window.


Display Settings

The display settings panel offers various options for adjusting the displayed pixel colors. The panel can be opened by clicking on the small arrow icon on the right side of the IPR window.

Enable Filter

Applies the settings when enabled.

Color Correction

Enables color correction.

Saturation

Scales the saturation by this factor.

Brightness

Scales the brightness by this factor.

Contrast

Scales the contrast by this factor.

Exposure

Exposes the displayed image up or down, in f-stops.

Gamma

Adjusts the displayed colors with a simple gamma curve.

Channel

Specifies which channels of the selected AOV (or beauty) is displayed.

Invert

Inverts the displayed RGB color.

Color Lookup

Enables color lookup. Color lookup allows you to change the overall appearance of the rendered image by choosing a new "look" from a list of presets. The presets are known as lookup tables or LUTs. A LUT contains instructions how to remap the original colors to different, specific colors creating a certain look.

.cube and .3dl LUT files are supported.

Directory

Specifies the root directory where the LUT files are located.

LUT

The list of LUT files located under the selected root directory and any of its subdirectories. Use the arrow buttons to quickly select the previous or next LUT file in the list.

Intensity

Specifies the intensity of remapping, 0% meaning no remap, 100% is full remap.
 

The display settings affect only the IPR window, they have no effect on the PV or batch render.

  • No labels