Download and Installation

Arnold, KtoA, and other downloads are available here. Installation instructions come with KtoA, but can also be viewed here: Installation.

Compatibility

  • Arnold: 5.2.1
  • Katana: 2.5v6+, 2.6v1+, 3.0v1+
  • Platforms:
    • Linux: x86-64, RHEL 6+ or compatible glibc
    • Windows: 7+ on x86-64, with VC++ 2015 redistributable installed

Enhancements

Incompatible Changes

  • Override behavior for built-in Katana parameters for Arnold plugins: Katana produces four built-in parameters for Arnold procedural, volume and implicit locations (frame, shutter, cropwindow and katanaFullName). These can conflict with parameters on the Arnold plugin, and it was previously difficult to override the built-in values. Now, any parameters of the same name that are explicitly set will override the built-in values without complaint. (#342)

Bug Fixes

  • #342 Override renderer procedural built-in parameters when set directly

  • #345 Invalid curves num points array causes crash

  • #346 Potential crash for procs/plugins with zero-sized arrays
  • #348 geometry.point.constantwidth attribute is ignored on pointclouds in KtoA 2.1.X and up

 

  • No labels