Rendering your first scene

In this tutorial, we'll cover some of the basics of working with Arnold in Softimage. It is assumed that you have already installed the SItoA addon in a workgroup, and (optionally) set up your Arnold license.

Changing the Scene Renderer

  • The first thing to do is to make Arnold the scene render. Open the Render Manager and in the Scene Render Options, select Arnold Renderer as the Scene Renderer.

 

You will have to do this for any scene you open that was using a different renderer.

If you want Arnold to be the default scene renderer for new scenes, then in the Render Manager explorer, click Edit > Open Rendering Preferences and click Arnold Renderer in the Rendering Engine list.

 

When Arnold is the default renderer, the SItoA addon automatically sets up new scenes to work with Arnold:

  • Create a default Arnold light.
  • Add the Arnold render channels (also known as AOVs in Arnold).
  • Make sure the render regions use the Arnold Renderer.

Working with Arnold in Softimage

The Arnold menu gives you quick access to Arnold lights, shaders, properties, and commands.

 

The Arnold Render Options control render settings at the scene or pass level. You can access the Arnold render options in the Render Manager, or by clicking Render > Renderer Options in the Render toolbar.

 

In the Render Tree preset manager, the Arnold shaders appear in the SItoA category. SItoA also supports most of the built-in Softimage shaders (see here for the complete list of supported Softimage shaders).

 


Setting up Arnold Shading and Lighting

Start a New Scene

Let's create a simple scene and set up some Arnold lights and shaders.

 

Open the script editor (press Alt+4), copy and paste this VBScript, and click  (Run) to create to create a new scene with a floor, a lizard, and a couple of cubes.

 Expand source

If you made Arnold the default scene renderer, then your new scene will have an Arnold distant light. And since SItoA includes an implementation of the Phong shader, which is the default shader for new objects in Softimage, you could now draw a render region and see some results.

Before you continue, make sure that Arnold is the scene renderer.

Set up a Spot Light

By default, a new scene has a distant light (if Arnold is the default scene renderer) or an infinite light (if mental ray is the default). We'll replace that default light with an Arnold spot light.

  1. Open the Material Manager, and change the default Scene_Material to use an Arnold Standard Surface shader instead of a Phong.  The Standard Surface shader is a multi-purpose shader capable of producing all types of materials, from simple plastic to car paint or skin, with effects like sub-surface scattering and transmission. 
  2. Delete the default light.
  3. On the render toolbar, click Modify > Ambience, and turn the global ambience down to 0,0,0.
  4. In the main menu bar, click Arnold > Lights > Spot.
  5. Switch to a spotlight view



and then navigate to a view like this:


The Spot light should be positioned at about roughly -15,5,5. You can always use the Transform panel in the MPC to enter a specific XYZ position for the light.

  1. Middle-click the Views menu to switch back to the Camera view.
  2. Draw a render region. 

    The render is probably totally black, or at least very dark unless you positioned the Spot quite close to the objects. That's because, by default, Arnold uses physically-correct quadratic decay for lights. Quadratic decay follows the inverse-square law, so an object (of the same size) twice as far away, receives only one-quarter the light.

  3. Open the property page for the spot light, and adjust the Intensity and Exposure values to get more light.

 

In Arnold, the total intensity of the light is computed with the following formula: color * intensity * 2exposure. You can get exactly the same output by changing either the intensity or the exposure. For example, intensity=1, exposure=4 is the same as intensity=16, exposure=0. Increasing the exposure by 1 results in double the amount of light.

  1. To get softer shadows, increase the Radius (under the Area group).

    With a non-zero value for radius, the light behaves more like a spherical source.The larger the radius, the softer the lighting from this light source ( zero radius gives hard shadows).

Set up object shading

Now, we'll apply Standard shaders to each object in the scene.

Applying the Arnold Standard Surface Shader

First, let's do the floor (the grid):

  1. Select the grid, and then click Arnold > Shaders > Standard Surface. This creates a new material that uses the Standard shader.  
  2. Depending on your Softimage settings, the Standard Surface shader property page (PPG) may (or may not) pop up automatically. If the PPG doesn't pop up automatically, click Render > Modify > Shader. 
  3. Connect a Checker Board shader to the Base Color. The Check Board shader is one of the Softimage shaders supported by Arnold.


 If you use an unsupported shader, such as Flagstone or Fractal, then when you render you'll see an "unable to load XXX from the Arnold plugins" error like this:

 

Now, let's do the lizard:

  1. Select the lizard and middle-click the Arnold menu (to repeat the last command and apply a Standard shader). 
  2. Adjust the Base Color to give the lizard a greenish hue.

 

 

Finally, let's assign Standard Surface shaders to the two cubes:

  1. Select cube and middle-click the Arnold menu (to repeat the last command and apply a Standard Surface shader).
  2. Select cube1 and middle-click the Arnold menu.

Opacity

Make one cube transparent:

  1. Select the cube and in the Arnold menu, click Properties > Parameters to add an Arnold Parameters property to the cube. 
  2. In the Arnold Parameters PPG, clear the Opaque check box. By default, all objects are opaque (non-transparent), so we need to turn this off if we want to make an object transparent using opacity.

 

  1. Open the Standard Surface shader PPG for cube (either by clicking Render > Modify > Shader or by pressing 7 to open the Render Tree). 
  2. In the Geometry tab of the Standard Surface shader PPG, change the Opacity Color to something like 0.2, 0.2, 0.2.

 

Transmission

You can use Transmission instead, and leave the opacity at 1,1,1 and the Opaque check box selected (which will give you faster renders). You can read more about Transmission and Opacity here. 


For the above example, I set Opaque = on in the Arnold Parameters of the cube. Then, in the Standard Surface shader applied to cube, I set the following:

  • Base color = 0.7, 0.7, 0.7
  • Transmission Color = 0.7, 0.7, 0.7
  • Transmission Depth = 1
  • IOR = 1.5
  • Opacity = 1,1,1
I also applied a Standard Surface shader to the second cube, and made it red so it stood out a bit more.

If I wanted colored shadows, I would set Opaque = off in the Arnold Parameters of the cube. Then the shadows would render with the refraction color.

 

 

Specular Reflection

Let's make the second cube more specular, to get some reflections of the lizard. Specular is direct and indirect reflections which can be made glossy (blurred).

  1. Select cube1 and open the Standard Surface shader PPG (either by clicking Render > Modify > Shader or by pressing 7 to open the Render Tree).
  2. In the Specular group, increase the Weight to 1, and in the Base group, decrease the Weight to 0.


Because the Specular Roughness is nonzero, you will get a glossy reflection:

 

  1. To get a mirror-like reflection, set the Roughness to 0:



 

  • No labels