Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

The creators of Katana were nice enough to provide us with a built-in test mesh. Everybody likes ponies, so they made it easy to get one. Choose Help > I want a pony.

 

Center

Image Modified

 

  • You must then create a minimal set of nodes in order to render anything. Hit the tab key and start typing the name of a node to get a filtered list of nodes; hit enter to accept, and then click the mouse to place the new node. Create the following node types:
  • CameraCreate
  • Merge
  • RenderSettings
  • Render

...

  • Form a node graph that looks like this by plugging outputs (bottom triangles) into inputs (top rectangles). Alternatively, hover over the node and press ` (backtick) over both nodes in turn. 
Center

Image Modified

 

  • Next, a note about the blue and green colored highlights on the nodes: blue corresponds to nodes that are viewed, e.g., the Scene Graph tab shows the state of the scene at the point that node is executed. If the CameraCreate node had the blue highlight clicked on, the only thing that would be in the Scene Graph would be the camera. If the Merge node has it, both the camera and the pony geometry are present. To set this click the left square or press V on the keyboard while hovering over the node. The green highlight indicates which node is being edited, and its parameters show up in the Parameters tab. To set this click the right square or press E while hovering over the node.

...

  • Click the green highlight on for the RenderSettings node, and change renderer to Arnold:
Center

Image RemovedImage Added

 

If Arnold is not an option in the renderer drop down, your KATANA_RESOURCES environment variable probably isn't pointed to the Arnold render resources, or Arnold itself is not available. Go back to the installation section to see how those are typically set up.

  • Now click the blue highlight for the Render node, and then right-click the node to get a small contextual menu. Select Preview Render. Now, switch to the Monitor tab (at the top-left of the window, near the Node Graph tab you already see) to see the render actually going. Hit the Home key on your keyboard to get it to its real size, and you should see the pony's hooves:
Center

Image Modified

 

You can see all of the console output from Arnold as it renders in the Render Log tab. When there are issues with the render, this is the first place you should look.

Center

Image Modified

 


Refinement

...

Try to get the pony centered in the view from various angles, and then zoom out and orient it something like this:

Center

Image Modified

 

  • Now, click back on the Node Graph tab, and hit tab to create a new node, of type ArnoldObjectSettings. You may drag the node (after it is placed) over the connection between the pony node and the Merge node to insert it along that connection:
Center

Image Modified

 

  • Click on its green highlight to edit it. This node needs a scenegraph location to run on, done using a CEL statement:
Center

Image Modified

 

  • In the Scene Graph tab, expand the scene graph until you see the pony (you may need to click the blue highlight on the pony node or further downstream nodes to see it):
Center

Image RemovedImage Added

 

  • Now, middle-click the pony item and drag it up to the Add Statements text in the node properties, so that it adds it to the CEL list. You can also shift+middle-mouse drag the pony node itself from the Node Graph to the Paths area to get the same result:
Center

Image RemovedImage Added

 

  • Now, expand the geometry parameters, and set the smoothing check box. Your final parameters should look like this:
Center

Image RemovedImage Added

 

  • Click the blue highlight on the Render node, and right-click it to run the Preview Render again. Switch to the Monitor tab, and now you should have something like this:
Center

Image Modified

 

Now go to Part 2 to add shader networks and lights.